Перейти к содержимому

Переход на сайт "1С Вопросы и ответы"
 

1С:Вопросы и ответы
Фото

Изменить название основания на печатной форме


  • Please log in to reply
4 ответов в этой теме

#1 Hayat

Hayat

    Newbie

  • Members
  • Pip
  • 3 сообщений

Отправлено 15 Май 2017 - 11:37

Добрый день!

Помогите, пжл, с кодом:

Мне нужно чтобы основание на печатной форме вышла на другом языке. Куда и в каком порядке нужно дописать код Нстр:

 

Если ТипЗнч(ДокументОбъект.ДокументОснование) = Тип("ДокументСсылка.РеализацияТоваров")ИЛИ 
ТипЗнч(ДокументОбъект.ДокументОснование) = Тип("ДокументСсылка.ЗакрытиеСмены") ИЛИ 
ТипЗнч(ДокументОбъект.ДокументОснование) = Тип("ДокументСсылка.ВводОстатковТоваров") ИЛИ 
ТипЗнч(ДокументОбъект.ДокументОснование) = Тип("ДокументСсылка.Инвентаризация") Тогда 
ОбластьМакета = Макет.ПолучитьОбласть("Основание"); 
ОбластьМакета.Параметры.ДокументОснованиеПредставление = спПолучитьНаименование(ДокументОбъект.ДокументОснование); 
ОбластьМакета.Параметры.ДокументОснование = ДокументОбъект.ДокументОснование; 
ТабДокумент.Вывести(ОбластьМакета); 
КонецЕсли;
 


#2 advanter

advanter

    Administrator

  • Administrators
  • 48 сообщений

Отправлено 15 Май 2017 - 01:13

 

Добрый день!

Помогите, пжл, с кодом:

Мне нужно чтобы основание на печатной форме вышла на другом языке. Куда и в каком порядке нужно дописать код Нстр:

 

Если ТипЗнч(ДокументОбъект.ДокументОснование) = Тип("ДокументСсылка.РеализацияТоваров")ИЛИ 
ТипЗнч(ДокументОбъект.ДокументОснование) = Тип("ДокументСсылка.ЗакрытиеСмены") ИЛИ 
ТипЗнч(ДокументОбъект.ДокументОснование) = Тип("ДокументСсылка.ВводОстатковТоваров") ИЛИ 
ТипЗнч(ДокументОбъект.ДокументОснование) = Тип("ДокументСсылка.Инвентаризация") Тогда 
ОбластьМакета = Макет.ПолучитьОбласть("Основание"); 
ОбластьМакета.Параметры.ДокументОснованиеПредставление = спПолучитьНаименование(ДокументОбъект.ДокументОснование); 
ОбластьМакета.Параметры.ДокументОснование = ДокументОбъект.ДокументОснование; 
ТабДокумент.Вывести(ОбластьМакета); 
КонецЕсли;

 

Функция НСтр применяется для строкового типа данных. Т.е. Вам сначала нужно определить то, чему будет присваиваться значение и его тип должен быть строка. Это, например, значение поля надписи, заголовка и т.д. 

Для примера:

КодЯзыкаПечать= "en";
ОбластьМакета.Параметры.ТекстЗаголовка = НСтр("ru=""Русский текст"";en=""English text"'", КодЯзыкаПечать);
В результате будет выведен текст "English text"'
Такой код можно разместить в любом месте с момента объявления области макета и до вывода этой области в табличном документе.


#3 Hayat

Hayat

    Newbie

  • Members
  • Pip
  • 3 сообщений

Отправлено 15 Май 2017 - 01:34

Тогда так должно выглядеть код:

 

ОбластьМакета.Параметры.ДокументОснованиеПредставление = НСтр("ru=""Реализация товаров"";uk=""Sale"'", uk);

ОбластьМакета.Параметры.ДокументОснованиеПредставление = НСтр("ru="" Инвентаризация"";uk="" Inventory"'", uk);

.....



#4 Hayat

Hayat

    Newbie

  • Members
  • Pip
  • 3 сообщений

Отправлено 15 Май 2017 - 01:37

 
{ВнешняяОбработка.ВозвратОтПокупателя.МодульОбъекта(19,96)}: Ожидается ключевое слово 'КонецФункции' ('EndFunction')
ОбластьМакета.Параметры.ДокументОснованиеПредставление = НСтр(ru=""Реализация товаров"";uk=""<<?>>Sale"'", uk); (Проверка: Толстый клиент (обычное приложение))


#5 advanter

advanter

    Administrator

  • Administrators
  • 48 сообщений

Отправлено 16 Май 2017 - 08:18

 

{ВнешняяОбработка.ВозвратОтПокупателя.МодульОбъекта(19,96)}: Ожидается ключевое слово 'КонецФункции' ('EndFunction')
ОбластьМакета.Параметры.ДокументОснованиеПредставление = НСтр(ru=""Реализация товаров"";uk=""<<?>>Sale"'", uk); (Проверка: Толстый клиент (обычное приложение))

 

 

...

Такой код можно разместить в любом месте с момента объявления области макета и до вывода этой области в табличном документе.

 

Нужно разместить код в нужном месте и закончить функцию конструкцией КонецФункции. Если параметр ДокументОснованиеПредставление имеет строковый тип и его заполнение соответствует нашим ожиданиям - то так.






0 посетителей читают эту тему

0 пользователей, 0 гостей, 0 скрытых

Copyright © 2018 Адвантер ЛВТИ